MW151RM3G安装OpenWRT

水星的MW151RM3G和TP-Link的TL-WR703N,他们的硬件是一模一样的,所以在MW151RM3G上安装703N的固件是完全可能的。掐指一算,手上已经买过十几个151RM了,用在了各种地方。

1

2

tplink和水星的在线升级程序根据固件文件的特定位置的特征值来判断固件是否匹配。

固件的中表示id是位置在 0x00000040 - 0x000047的数据
tplink 是 0703 0101 0000 0001
水星是 0703 0101 0001 0001

几年前,我把tplink的固件改成水性固件的id,就可以把水星路由器安装上tplink的固件,但是新买的两台路由器发现无法把我自己的程序写进去,好在网上有很多类似的固件下载,就可以刷成tplink的程序了。

接下来就是刷openwrt固件了。

在最新版的OpenWrt Attitude Adjustment(AA)中,可以看到和703N相关的4个文件

openwrt-ar71xx-generic-tl-wr703n-v1-jffs2-factory.bin
openwrt-ar71xx-generic-tl-wr703n-v1-jffs2-sysupgrade.bin
openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin

jffs2 和 squashfs是两种文件格式,squashfs是只读格式,通过对文件的重定向可以对文件系统进行压缩,比jffs2体积小20%以上。

factory中的固件是带数据区域的,当其他固件刷成openwrt时,应该使用这个。而sysupgrade中是不带数据分区的,openwrt升级时,可以使用这个。http://heqichen.cn/wp/wp-admin/post-new.php

但是当我刷jffs2的时候,151rm就变砖了,原因还没分析。

本来不想打开的,没办法,必须要用串口去刷机了。

 

MW151R3G

找到相应的测试点,焊好线。

3

测试好没问题的话,就可以用胶封起来了,因为测试点太小,如果焊盘掉了就非常难焊,这个需要注意。

4

连好串口,开始刷机。

5

刷机过程就和openwrt官网说的一样
http://forums.openpilot.org/blog/52/entry-92-unbrick-wr703n-wifi-router/

 

  1. 用网线链接主机和路由器
  2. 主机设置静态ip : 192.168.1.100
  3. 主机配置tftp服务器,并准备固件
  4. 在路由器上执行以下命令
    1. 在开机时按tpl进入bootloader
    2. hornet> tftpboot 0x81000000 openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
      hornet> erase 0x9f020000 +0x3c0000
      hornet> cp.b 0x81000000 0x9f020000 0x3c0000
      hornet> bootm 9f020000

在ubuntu上建立tftp服务器也折腾了我很久,tftpd-hpa配置太复杂。。最后改用了atftpd。
atftpd启动时一定要用--daemon启动。然后说是说目录是/tftpboot,但是没有起作用,自己定义directory也没有起作用。最后先主机上tftp,把固件上传到tftp服务器上,也不知道atftpd把这个文件放到那个文件夹下面了,再由路由器去连接tftp服务器下载固件才刷了机。。。

 

openwrt成功启动后,进入openwrt,一开始可以使用有线链接,telnet进去
telnet 192.168.1.1

修改 /etc/config/wireless
注释掉   # option disabled 1  以打开无线功能
reboot

修改 /etc/config/network
注释掉 config interface 'lan'下面的这一行
#   option ifname 'eth0'
最下方增加:
config interface 'wan'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.***.***'  #此处是上次网关分配的固定IP,也可以dhcp。
option netmask '255.255.255.0'
option gateway '192.168.***.254'  #网关地址
option dns '**

我的设置是
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
reboot

然后可以用passwd设置root的密码,其他的设置可以到界面上进行设置了。

 

 

 

1,296 total views, 2 views today

Leave a Reply